Перейти к содержанию
  • 0

В порту USB шлема вода или мусор


Varset

Вопрос

  • Модераторы

Давеча подхватил интересную проблему... Но это сейчас она кажется интересной, а сначала просто удивлен был.

В шлеме всплыло  сообщение о том, что в разъеме мусор или вода, прежде почистите, а потом поговорим.

При этом сидел себе как обычно, играл в Сабнавтику по VD, шлем подключен к банке, как сто раз до того. И тут такое:

Как это выглядит

usberror.jpg.b7674502c86db69602b878cc3da27cf1.jpg

 

Ломал голову какое-то время, а потом заметил что разъем переходника чуть перекошен в горизонтальной плоскости. Кабель жесткий, вот и перекосило. Хотя не должно было.

Сменил переходник, плотно воткнул и закрепил, больше сообщение не появлялось ни разу

Ссылка на комментарий
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0
  • Модераторы

Окно закрыл, пожал плечами, играю дальше. Периодически меняю занятие - ваяю Квас. В очередной раз пытаюсь идентифицировать внешние камеры по изменению температуры, и обнаруживаю, что температуры-то и нет. И тут он (Квас) мне не показывает температуру. Вообще никакую - CPU/GPU/Батарея/Корпус/Камеры и т.д, там этих датчиков штук пятьдесят. И ни один не отображает градусы. Лезу в dumpsys - там пусто. И варниг о том, что некий датчик не может отдать температуру, потому что его, видите ли, нет. Лезу в предыдущий dumpsys, слитый тремя днями раньше - все есть. И тот датчик тоже. А шлем вот как раз обновился на 62... 

Обращаюсь к одному джентльмену с просьбой, он присылает мне свой дамп - там все есть и Квас показывает температуру как надо.

Обдумываю письмо в тех поддкржку и возврат и параллельно осматриваю переходник, подключенный к разъему шлема, а он - перекошен, в горизонтальной плоскости. Выдернул, перезагрузил, подключил без него - все нормально, датчики появились, темература отображается. Подключаю переходник, уже прямо, тоже все работает.

Блин, до этого момента я и не предполагал, что разъем может встать криво, ну не встает он никогда таким таким образом! Попробовал на IQOS, на телефоне - чуть-чуть люфтит, но и только! В общем, имейте в виду, разъем в шлеме так себе. А то что такое окошко начало появляться - это гуд, значит в разъеме замыкание. Вот только непонятно причем здесь температурные датчики...

 

Как так получается и как это выглядит.

Так как кабель переходника очень жесткий, то при прижиме или сгибании кабеля его разъем перекашивается в гнезде.

Чтобы этого не случалось, между креплением шлема и кабелем следует поставить небольшую "подушку", например из жесткого поролона.

В этом случае даже будучи крепко прижатым к креплению, кабель перекашиваться не будет:

norm.jpg.4acf9b147587b88402cf820b86fc198e.jpg

 

А здесь я иллюстрирую тот самый горизонтальный перекос. Специально надавливаю на "подушку", эмулируя прижим кабеля к креплению, когда никакой подушки нет. И хорошо видно, как именно перекашивается кабель:

perekos.jpg.6d09f3f8ec2df10ba16b2094fa43ccb7.jpg

 

Это сейчас не баг, а фича. Но остается вопрос - зачем это сделано?...

Предполагаю, что инженеры Мета забодались получать жалобы на поджаренные разъемы и теперь просто отключают его программно. Но с другой стороны - довольно странное решение - отрубать датчики и передачу данных, но оставлять зарядку. Впрочем, возможно зарядки там, как таковой нет, но это нужно выяснять USB тестером.

Ссылка на комментарий
Поделиться на другие сайты

  • 0

Тоже один раз ловил такое сообщение, не придал значения 

Ссылка на комментарий
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйте новый аккаунт в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
×
×
  • Создать...

Важная информация

Правила пользования сайтом Условия использования